Dynamic Link not found - Google Assistant (and Firebase)


#1

Hello,

I’ve been advised by your support team (ref: ref:_00D40Mlt9._5001W1Pbasq:ref) - was talking with Stefan - to raise this issue here. I appreciate that this is a developer community forum, and not really designed for product support, but all my options have been exhausted.

I’m attempting to enable the Google Assistant integration for my Nest IQ Indoor camera. I’m presented with the option to add it, and press “Get Started”. My phone’s (and tablet, tried it on there too) browser opens, and I’m presented with the error:

Dynamic Link not found

There’s wording about “if you’re the developer of this app, ensure your Dynamic Links domain is correctly configured and that the path component of the URL is valid”.

We’ve gone through various steps, e.g. factory reset of the camera, re-adding the device to my account, even going into the Google Home app and re-linking the Nest Service, all to no avail.

The URL in question in the browser is as follows:

https://goo.gl/app/search/?link=https://assistant.google.com&apn=com.google.android.googlequicksearchbox&amv=300756684&al=googleapp://deeplink/?data=CksBDb3mGzBEAiAaPELPfHOd6ZxNLMTAGAZ0U3115jlq2Jvk45ZPqw_n5wIgdCiOqIZsGyqULdKQn5cQKKMkkX9T3_JTNHuXF347LfUSmgEKBgjM3bSPARIHCAESA29wYRphEl8IBBJb6oqo9ARVCAMaEGNvbS5uZXN0LmFuZHJvaWQiGG5lc3QtaG9tZS1hc3Npc3RhbnQtcHJvZCoPbmVzdF90aGVybW9zdGF0MhJuZXN0LnVsdHJhdm94LnByb2Q4ASIkCiJodHRwOi8vYXNzaXN0YW50Lmdvb2dsZS5jb20vZGV2aWNl&_nr=1

The error page is as follows:

I’ve contacted the Google Assistant team and as expected they just redirected me back to your nest cam specialist team.

As a application developer myself, it seems like something in the app is malforming the URL. However without access to the code base I could just be talking rubbish.

Any assistance would be appreciated!


#2

Hi there,

Just to be clear, you’re following the instructions here and it’s not working?

Exactly what steps (full reproducible steps) are you taking to get to that error?


#3

Hi @jbumgardner, thanks for getting back to me.

My exact steps to get to this point are as follows, context being from within the Nest Android App:

  1. Add the Nest IQ Indoor camera to my Nest Account, named “Living room”
  2. From the main menu (where it shows all your cameras, thermostats, protects etc), tap the cog top right to go into settings
  3. Scroll down to find the “Living room” camera and tapping it on it
  4. In the “Living room” camera settings, pressing the button titled “Add Google Assistant”
  5. Presented with a screen titled “Talk to your Google Assistant on Nest Cam IQ”
  6. Press the “Get started” blue button at the bottom
  7. Chrome on my phone opens with the above linked in the OP
  8. Presented with “Dynamic Link not found error”

Diagnostic procedures taken, all resulting in the same issue:

  • Uninstalled the Nest App from my phone (Samsung Galaxy S7 Edge), reinstalled it and went through the process of removing and adding the camera to my account.
  • Removed the camera from my nest account first, THEN reinstalled the app and re-added the camera.
  • Force reseted the camera with the tiny button on the base of it (the front ring glowed yellow and then I went through the process of adding the camera again with the agent)
  • Installed the Nest App on an Android Tablet (Samsung Galaxy Tab 2) and re-added the camera
  • Ensured that my Google Home address (of my house) is the exact same as the Nest address (some reported that this fixed it for them)
  • Ensured that my WiFi wasn’t blocking anything (I even disabled my firewall thinking it was that)
  • Loaded the link into another browser (Firefox) and on another device (Tablet) and still presented with the error
  • The device has strong 5G signal to my wifi router
  • The device has a reliable power connection
  • The device is able to stream video and audio to me in real time as does all the other cameras in the house
  • The device has a valid local IP and is being detected on the network correctly
  • My Google account is active and isn’t banned or anything
  • Google Assistant works streaming FROM the camera - I can say “Hey Google, show me the Living Room” on my Google Home Hub and it will successfully stream the living room camera feed to my hub

As a developer myself (and this is likely a wrong opinion but…) it seems to be something that’s attempting to generate a smart link with some data in it and Googles rejecting it for some reason.

Device info:

Model: Nest Cam IQ
Software: 4620002

Serial number and MAC address can be provided upon request if you require it


#4

Also since videos are the holy grail for debugging, here you go:


#5

Bizzarely it’s working all over a sudden! No idea why it’s working now… It’s correctly paired with my Google account and it’s responding as it should. No updates on my phone for the nest app or the Google home app. /shrug


#6

Ha well I was going to check in to say that we couldn’t reproduce, so glad to hear it resolved itself! :slight_smile: