Embed stream + autoplay = not working


#1

Go to any public stream, we’ll use this one as an example:

Click the “Embed stream” button

Here’s the code for “enable autoplay”

Here’s the code for “enable autoplay” unchecked:

As you can see the only difference is a query parameter of “autoplay=0”

No matter which way you try this, it will never autoplay. This functionality was working for us about ~2 weeks ago now, so something has changed on the nest side and this “embed stream” with “autoplay” control isn’t even working.

Any help or guidance on how to fix this issue is greatly appreciated. Also love to hear from the Nest team as this isn’t working on their website right now for ALL of their customers. This is NOT an isolated issue. Everyone is effected.


#2

Hey there @rricketts , we have someone taking a look, I’ll get back to you once I hear anything.


#3

Thanks. When do you expect to hear back?


#4

Any update on this?


#5

Someone’s investigating, but I don’t have any timeline on a fix. This is not WWN API functionality so it’s handled by a different team.


#6

Any update on this?


#7

They are actively looking at it, but I don’t have a timeline for a fix.


#8

Is this a week? a month? next year? Please let me know either way. Happy to be patient just need to have some sort of idea.


#9

Hi Jeff,

Any update on this?


#10

They were checking on it yesterday, and it’s primarily due to the changes for autoplay preferences that browsers implemented earlier this year (it’s broken for Chrome, Firefox, and Safari, at least). Videos are generally blocked from playing by default and fixes require changes to each individual website. So we have to make updates to nest.com itself.

Since the functionality is essentially disabled, for the moment they’re going to remove the autoplay option in the embed URL to reduce confusion. They do plan to fix it but for now there’s no autoplay, and unfortunately I don’t have a timeline for the actual fix.


#11

There are other browsers that use and work with this functionality (think WebView), is there anyway you could leave it in? remove the checkbox for mainstream, but restore autoplay functionality with the autoplay=1 query flag


#12

They’re just removing the checkbox to get an embed URL with the autoplay parameter, so people aren’t confused when it doesn’t work. When they fix the underlying issue they’ll put the checkbox back. If there’s a browser where autoplay is currently working it’ll still continue to work. It’s just that the functionality is unreliable enough for us to consider it effectively disabled.


#13

Any idea as to why it was working for me (for 12+ months) and then one day stopped working? Again, testing it in a browsers that work with video’s autoplaying. No change on the browser end.


#14

No, I have no idea… nothing was changed on the nest.com side to change the functionality. It’s mostly due to browser updates from what I know.


#15

Any update? Looks like a few others have reported the same issue.


#16

Why is this taking so long? The dropcam’s are useless for us this way. We really need the ability to autoplay the videostreams in an iframe. Like we could before the html5/chrome66 updates.


#17

Chrome made the change, not Nest. There’s no guarantee any developer can make this work in Chrome 66+ without Google reverting some of their code changes, which they’ve come out and have said it was on purpose.

My original question and concern was why did this functionality change for me when my browser version has not changed in the duration it was working and now no longer works.

At this current moment, this issue has not been patched so I do believe there’s still an autoplay problem within Nest’s code base for dropcam. Hopefully they can find it and patch it as this would lead to the issue possibly being resolved for you as well.