Enable no-audio in iFrame for mobile autoplay


#1

When watching camera in webview on android, user has to always tap on play button prior to streaming to begin. Even with autoplay=1 parameter. I did some digging and found where console outputs the following:
Uncaught (in promise) NotAllowedError: play() can only be initiated by a user gesture.", source: https://video.nest.com/vendor/video.min.js (18)

As i understand autoplay may not be running because of the audio in an output stream. Is there a way to disable audio (maybe add smth like audio=0 to the iframe link?)


Iframe nest video to provide autoplay
#2

Hey hello,
did you find a solution for that? I am experiencing the very same problem

thanks


#3

Unfortunately I wasn’t able to find a solution for that. This is very annoying but seems like is the only way this can be done. I was going to make an alexa skill that allows me to view the cameras on my TV in a browser window, but this issue renders it all useless, because there is no way I can click play on a TV. I really like nest cameras but this issue making me look at some other options just to see the areas I need to view on TV.


#4

I have been trying to do the same thing but for use in a smart mirror setup. The camera feed comes up in an iframe but doesn’t autoplay.

I tried disabling the audio in the settings on the camera but this doesn’t make any difference and using the ?autoplay=1 command at the end of the url but this doesn’t help either.

I had seen posting on a forum for actiontiles where people had a similar issue - one thought was that the issue might have been the browser?

But for now I’m totally stumped too…


#5

Has there been any update to this? Being able to autoplay is incredibly important for integrating with others.


#6

Not as I’m aware of. Looks like NEST stays pretty quiet about it.