Iframe nest video to provide autoplay


#1

Good afternoon,

I am having an issue with Nest Camera. I am currently using embedded iframe to get the content of the video stream with these attributes

id=’…’ allowfullscreen webkitallowfullscreen mozallowfullscreen frameborder=‘0’ width=‘720’ height=‘405’ src=‘https://video.nest.com/embedded/live/url

I really liked it because the video was auto-playing by default until few days ago. Then something changed and now we need to press play manually to have it working.

I really need the possibility to autoplay, could you please help me? I have also tried to append ?autoplay to the url but that doesn’t work.

Thank you very much :slight_smile:

Simo


Embed stream + autoplay = not working
#2

I am using a nest camera stream embedded in an iframe on my smart mirror and have the exact same problem…

the ?autoplay command doesn’t make a difference either when in an iframe

however the ?autoplay command does work when using the camera stream not in an iframe

Any help appreciated also!!


#3

Maybe this is related to the sound being enabled?

Enable no-audio in iFrame for mobile autoplay


#4

Hello, is there any progress since the last time? It’s making the embedded videos kind of useless + the modal window which you click on for more info and the whole iframe is blank after.


#5

Probably related to this:

https://nestdevelopers.io/t/embed-stream-autoplay-not-working/1692/15

The web team is aware of the issue and plans to fix, but I don’t know when.