Owner Permitted and connection available device not available


#1

Hi
I installed a new Nest thermostat and also created my owner and developer accounts. From my developer account I used the authorization url to generate the pin code for my Nest account.

Under my owner Nest account settings on clicking Works with Nest, I see that my developer account has a connection. In fact I have tried this multiple times and have upto 5 connections listed.

Using the pincode I got the authorization token using the api. Using this token, I try to get devices from https://developer-api.nest.com

The response is 200 OK and the following response header -

content-type: application/json; charset=UTF-8 access-control-allow-origin: * cache-control: private, no-cache, no-store, max-age=0 pragma: no-cache connection: close content-length:2 {}

It does return the device ID of my thermostat that is added to my account. Without the device ID I am unable to access the thermostat using my app. Please help. Thanks


#2

How are you making the call to get the JSON for your authorized account? Can you post the code and the actual result?


#3

Thanks.

I probably was not using the owner account. I had another account created with full permissions and it showed all the connections, but still that did not work.

Logging with the first created account solved the issue.

Is it possible to create another account with full permission as the owner and can be used to provide permissions ?


#4

The owner of a structure has to authorize a WWN connection for it work properly, and there can only be one owner on an account. Once you get the authorization token using the owner’s account, the account doesn’t matter, just make your API calls with that token.