Simulator Camera not streaming video

simulator

#1

Hi There, I am new to Nest development, I have added a camera on Nest Home Simulator and accessing the camera stream using API’s web_url property, however camera is not streaming anything in the web_url returned! Am I missing something ? Kinldy help. Thanks in advance :slight_smile:


#2

Welcome and thank you for your question,
the product team is looking into this issue. - Mimi


#3

Hi bpillai -

Cameras in the Home Simulator can’t stream anything… they aren’t real cameras. This is working as intended.

If you actually want to test the functionality of presenting the web_url in a browser, you’ll need to have a real camera.


#4

Hi jbumgardner,

I have found the root cause of the NEST Home Simulator’ camera streaming issue. The issue is the camera streams the fake/dummy stream on the America/New York timezone. So when we try to get the camera’s stream from other timezone(eg. Indian Standard Time) I get a blank stream.

However when I try to request the camera stream after 18.00 Indian Standard Time (It may be 9.00 in New York), I am getting the fake/dummy stream from the camera.

My suggestion would be, Camera should send the dummy/fake stream irrespective of timezone or other parameter. As its is dummy it should stream always :stuck_out_tongue:

Thanks for the Information :slight_smile:


#5

Ah, I see what you mean, thanks for clarifying. Not sure if this will ever be changed, but hopefully understanding how it works helps you out.